Precision Racing League

Register a free account today to become a member! Once signed in, you'll be able to participate on this site and signup to race in our different series but firstly make sure you head over to the "New Members Start Here" in the League Information section.

thrustmaster not recognized


Well-known member
Daniel Barnett
Mar 22, 2017
iRacing ID
[font=Arial,Helvetica,Verdana,sans-serif]I installed a CPU cooler on Thursday, and decided to remove the CPU to clean the thermal paste. Plugged everything back in and all seemed fine. Joined a race and the steering was all wonky, with slight movements causing severe left and right movements, so I figured it was a calibration issue and would deal with it on Friday. Well, launched thrustmaster control panel and it took me to the same screen as joy.cpl command does and the wheel is not shown, yet my DSD track boss was. [/font]
[font=Arial,Helvetica,Verdana,sans-serif] So I downloaded the newest driver and followed the instructions, even putting the original wheel back on. Still not recognized, upon pc startup all looks good, it spins left and right, all lights on, but once my password screen comes up, no lights and not showing. Tested wheel on my sons xbox and works fine, installed on his pc and all is fine, have tried every usb slot on my pc as suggested in another persons thread, even tried installing an older driver from 2017 and still nothing. Can't even launch the bootloader as suggested by the TM support site, and they won't respond for at least 15 days according to the support email I got back from them. [/font]
[font=Arial,Helvetica,Verdana,sans-serif] Any Ideas????? [/font]

[font=Arial,Helvetica,Verdana,sans-serif] dan [/font]
Any firmware update?

That's really weird... Does the wheel works good on another racing game on your computer?
I am hoping it is just a firmware update, going to try the Boot Loader on my son's computer today to see if that works. Others have suggested it may be a USB issue, not sure how to check that other than to plug things into them which I have done and those devices have worked

Well to test USB, you would need an USB card to have something different them the one built-in the motherboard.
jeromef1 said:
Well to test USB, you would need an USB card to have something different them the one built-in the motherboard.

Tested in the usb card that runs the occulus, no go there either.
SharkV said:
Before installing new drivers, did you unplugged everything, and uninstall the drivers, then start like new....

No, not the first time, I just launched the thrustmaster update from the folder as I didn't see the correct setup screen for it.  When that failed I deleted everything I could find that said thrustmaster and downloaded the newest driver, installed and uninstalled several times with still no luck. This is what it says when I look at it in device manager::   Thustmaster TX GIP Racing Wheel, when I click on events I get this message::      Device SWD\WPDBUSENUM\_??_USBSTOR#Disk&Ven_SMI&Prod_USB_DISK&Rev_1100#7&6062d6a&1#{53f56307-b6bf-11d0-94f2-00a0c91efb8b} requires further installation.
Ouffff.... Windows is up to date?

I would say you should google this error.
jeromef1 said:
Ouffff.... Windows is up to date?

I would say you should google this error.

Just tells you to reinstall the drivers for the device.  I did some work on the wheel today and started digging around.  Sorry about the copy and paste, but am on several forums trying to find the fix.

UPDATE:  was able to get the bootloader program to run on my son's computer with no issues, put wheel back on my computer and still have same issue, so I started the bootloader program on my computer and I get this message.
     "ERROR: time-out device should have arrived in BULK. (Code:0x34100001). this code just sends you to the bootloader program walkthrough.
 Under device manager I get this message:   "Device USB\VID_044F&PID_B664\0000D42361341801 requires further installation."
 I then look at driver details:   "no driver files are required or have been loaded for this device"

So I then click on update driver "Windows encountered a problem installing the drivers for your device, windows found drivers for your device but encountered and error while attempting to install them.  Thrustmaster TX racing wheel (gip_mode_selector).   One of the installers for this device cannot perform the installation at this time.  see manufacturer for latest drivers."

I checked the other usb devices on my computer and they are recognized in every port, so I am guessing my driver download is bad, yet  the one I downloaded on my son's is good.  I have downloaded this driver so many times on my computer I must have gotten a good version by now.  According to MSI I am up to date on MOBO drivers, and as suggested I looked at the bios but did not see anything about USB ports.
Working on a complete reinstall of win10 and all programs and drivers which hopefully fixes the issues. Will update later. Dany and Jerome thanks for the help and links. If this doesn't work a fanatec system will be on the way.

Up and running. Now just getting all the settings back to the way I like it